Cisco 881 Router with PPPoE connection over external ADSL Modem

Lately a partners inquiry whether can Cisco 881/K9 router (without ADSL module) connected to the ISP (Internet Service Provider) using external ADSL Modem which the ADSL set to bridge mode, and let the Cisco 881/k9 do the PPPoE dial up

As usual configuration, we let the ADSL modem do it work (PPPoE dial up at ADSL Modem) and let the router connect to Modem via the LAN/WAN. Unfortunately, the End user would like to set the modem into bridge mode, and let the Cisco 881 do the PPPoE dial up.

I try to search around, but unable to locate a confirmation from Cisco’s official website. after few more attempt on searching, found a question online which similar to my partners’s inquiry

I am attempting to setup a Cisco 881G router that uses FastEthernet 4 for the WAN interface to utilize an ADSL Modem. How does this configuration work. Since the modem does the PPPoE do I also have to setup the Router to do PPPoE?

This is few answer from the expert:

1. You could have the ADSL modem/router do the PPPoE + NAT and then have your 881G do NAT again behind it.

or..

2. You can turn off PPPoE on the ADSL modem and have it run in bridging mode only. On the Cisco you would then do something like this:

interface FastEthernet4
description Physical WAN Interface
bandwidth inherit
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
hold-queue 224 in
!

interface Dialer0
ip address negotiated
ip verify unicast reverse-path
no ip redirects
no ip unreachables
ip directed-broadcast
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1400
load-interval 30
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname xxxxx@yyyyy.zzz
ppp chap password xxxxxxxxxxxxxxxxx

Other then the above answer, which the option 2 is pretty much answer my doubt on Cisco 881 with PPPoE connection which the external ADSL modem been set to bridge mode.

While at the same time, there is another expert do comment another method:

You will need to setup F0/4 as a pppoe interface and point it to the proper dial pool. then configure the dialer interface . next create a route pointing all lan traffic to the dialer interface.

Nat will also need to be setup so your internal lan computers can use the internet.

here is a sample config for you

 


interface Ethernet0/4
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 1
!
ip route 0.0.0.0 0.0.0.0 interface dialer0
!
!you will also need to configure NAT/PAT for address translation
!
ip nat inside source list 100 interface dialer0 overload
access-list 100 permit ip <internal subnet> <mask> any
!
interface Dialer0
ip nat outside
!
!any interface connecting to your local lan needs ip nat inside
interface f0/0
ip nat inside
No comments yet.

Leave a Reply